Compartilhe
Ir em baixo
Mensagens : 6
Data de inscrição : 15/09/2017
Ver perfil do usuário

João Pedro França da Conceição RA:4885668602 2º Período

em Qua Nov 22, 2017 5:28 pm
faça um algoritmo em python que solicite ao usuário números e os armazene em uma matriz 6×6. Em seguida, crie um vetor que armazene os elementos da diagonal principal da matriz.

vet = [0]*6
mat = [0]*6
for x in range(6):
mat[x] = [0]*6

for lin in range(6):
for col in range(6):
mat[lin][col] = input('Digite um valor: ')
print mat

for lin in range(6):
for col in range(6):
print lin,col
if lin == col:
print 'DP', lin, col
vet[lin] = mat[lin][col]
print vet
Mensagens : 4
Data de inscrição : 19/09/2017
Ver perfil do usuário

Re: Exercício 6 - 16/11/2017

em Qua Nov 22, 2017 6:05 pm
Fernando Ferreira da Silva
Ra: 4885691875

Crie um aplicativo em Java que peça ao usuário para preencher uma matriz 3x2 com valores inteiros e depois exiba essa matriz.

import java.util.Scanner;

public class matrizTeste2 {

public static void main(String[] args){
int[][] matriz = new int[3][2];

Scanner entrada = new Scanner(System.in);
System.out.println("Matriz M[3][2]\n");

for(int linha=0 ; linha < 3 ; linha++){
for(int coluna = 0; coluna < 2 ; coluna ++){
System.out.printf("Insira o elemento M[%d][%d]: ",linha+1,coluna+1);
matriz[linha][coluna]=entrada.nextInt();
}
}

System.out.println("\nA Matriz ficou: \n");
for(int linha=0 ; linha < 3 ; linha++){
for(int coluna = 0; coluna < 2 ; coluna ++){
System.out.printf("\t %d \t",matriz[linha][coluna]);
}
System.out.println();
}

}


}
Mensagens : 6
Data de inscrição : 05/09/2017
Ver perfil do usuário

Karina Monteiro Borges RA:4885695501

em Qua Nov 22, 2017 7:13 pm
Programa em c
Programa usa matriz de duas dimensões para criar 50 combinações para a loteria (SENA).

/*loteria.c*/
/*Imprime 50 combinações de jogos para a sena */
#include <stdio.h>
#include <stdlib.h>
#define JOGOS 50
#define N 6

int main()
{
int matriz[JOGOS][N],k, j;
for(k = 0; k < JOGOS; k++)
for(j = 0; j < N; j++)
matriz[k][j]=rand()%60+1; /* Número aeleatório de 1 a 60 */
for(k = 0; k < JOGOS; k++)
{
printf("Combinação %2d; ", k+1);
for(j = 0; j < N; j++)/* Imprime as dezenas na tela */
printf("%2d ",matriz[k][j]);
printf("\n");
}
system("PAUSE");
return 0;
}
Mensagens : 4
Data de inscrição : 18/09/2017
Ver perfil do usuário

Re: Exercício 6 - 16/11/2017

em Qua Nov 22, 2017 8:38 pm
ALFREDO DA SILVA NETO
RA: 4885743516


Faça um algoritmo para ler uma matriz de 3×4 de números reais e depois exibir o elemento do canto superior esquerdo e do canto inferior.

algoritmo “Estudando Matriz”

// Função : Faça um algoritmo para ler uma matriz de 3×4 de números reais
// e depois exibir o elemento do canto superior esquerdo e do canto inferior direito
// Autor : ALFREDO DA SILVA NETO
// Data : 22/11/2017
// Seção de Declarações

var
matriz : vetor[1..3,1..4] de real
i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 3 faca
para j de 1 ate 4 faca
escreva(“Digite um número inteiro: [“, i, “,”, j, “] “)
leia(matriz[i,j])
fimpara
fimpara

para i de 1 ate 3 faca
para j de 1 ate 4 faca
escreva(matriz[i,j]:3)
fimpara
escreval(“”)
fimpara
escreval(“”)
escreval(“linha 1 e coluna 1”, matriz[1,1])
escreval(“linha 3 e coluna 4”, matriz[3,4])

fimalgoritmo
Mensagens : 6
Data de inscrição : 14/09/2017
Ver perfil do usuário

Matheus da Costa martiniano Silva RA:5935491043 2 periodo

em Qua Nov 22, 2017 8:41 pm
Leia números de matrículas de alunos e armazene-os em um vetor até o vetor ser preenchido por 10 matrículas. Esses números são distintos, ou seja, o vetor não armazenará valores repetidos.

Programa em C

#include<math.h>
#include<stdio.h>
#include<string.h>

int main(){

int vetor[10], numero, cont, posicao = 0 ;

while (posicao < 10){

scanf("%d",&numero);

if (posicao == 0){
vetor[posicao] = numero;
printf("%d\n",vetor[posicao]);
posicao++;
}

else{

for(cont = 0; (cont < posicao)&&(vetor[cont]!= numero); cont++);

if (cont >= posicao){
vetor[posicao] = numero;
printf("%d\n",vetor[posicao]);
posicao++;
}
}
}
return 0;
}
Mensagens : 4
Data de inscrição : 20/09/2017
Ver perfil do usuário

Gabriel Lopes Siqueira/primeiro período/ RA.:2672275941

em Qua Nov 22, 2017 9:31 pm
/*Programa em java que gera uma matriz de elementos inteiros de 5 linhas e 6 colunas
* verificando se tem elementos repetidos, imprima a matriz e informa os elementos
* repetidos */

import java.util.Scanner;
import java.util.ArrayList;

public class M4{
public static void main(String[] args){
int[][] matriz = new int [5][6];

ArrayList<Integer> resultado = new ArrayList<Integer>();

Scanner entrada = new Scanner(System.in);
System.out.println("\nMatriz M[5][6]\n");
 
for(int linha = 0; linha < 5; linha++)
{
       for(int coluna = 0; coluna < 5; coluna++)
{
System.out.printf("Insira o elemento M:[%d][%d]:",linha+1,coluna+1);
matriz[linha][coluna] = entrada.nextInt();
}
}

for(int linha = 0; linha < 5; linha++)
{
for(int coluna=0; coluna < 6; coluna++)
System.out.printf("\t" + matriz[linha][coluna] );

System.out.println();
}

System.out.println();

for(int [] matrizA : matriz)
{
for(int valor : matrizA)
{
int count = 0;

if(resultado.contains(valor))
continue;

for(int valor1 : matrizA)
{
if(valor1 == valor)
{
count++;

if(count > 1)
{
resultado.add(valor1);
break;
}
}
}
}
}

for(int value : resultado)
System.out.println(resultado);
}
}
Mensagens : 6
Data de inscrição : 13/09/2017
Ver perfil do usuário

Thiago Teixeira e Silva - RA: 1842644835 - 2° Período

em Qua Nov 22, 2017 9:46 pm
Criar um algoritmo que leia os elementos de uma matriz inteira de 3 x 3 e imprimir outra
matriz multiplicando cada elemento da primeira matriz por 2.



#include <stdio.h>
#include <stdlib.h>
#include <conio.h>
#include <math.h>
#include <string.h>
main()
{
int lin,col, tab;
int mat[3][3], mat1[3][3];
for (lin=0; lin<3; lin++)
{
for (col=0; col<3;col++)
{
printf("Digite ELEMENTO da linha %d, coluna %d da matriz: ",lin+1,col+1);
scanf("%d", &mat[lin][col]);
}
}
printf("Matriz original\n");
for (lin=0;lin<=2;lin++)
{
for (col=0;col<3;col++)
printf("%d\t",mat[lin][col]);
printf("\n\n");
}
for (lin=0;lin<=2;lin++)
for (col=0;col<3;col++)
mat1[lin][col] = (mat[lin][col])*2;
printf("\n\nMatriz com elementos multiplicados por 2\n\n");
for (lin=0;lin<=2;lin++)
{
for (col=0;col<3;col++)
printf("%d\t",mat1[lin][col]);
printf("\n\n");
}
printf("\n\n");
system("pause");
return 0;
}
Mensagens : 1
Data de inscrição : 22/11/2017
Ver perfil do usuário

Kazuya Aoyama RA:5637403055 2º período

em Qua Nov 22, 2017 10:09 pm
Programa que le uma matriz 5 x 2 que soma 10 em todos os numeros digitados

#include <stdio.h>
#include <stdlib.h>

int main ()
{
int i, j, m[5][2];

for(i=0;i<5;i++)
for(j=0;j<2;j++)

{
printf("numeros[%d][%d]= ",i,j);
scanf("%d",&m[i][j]);}

for(i=0;i<5;i++)
for(j=0;j<2;j++)
m[i][j]=m[i][j]+10;
printf("\n::: Cada um deles somados por 10:::\n");
for(i=0;i<5;i++) {
for(j=0;j<2;j++)
printf("%d ",m[i][j]);
printf("\n");
}

return 0;
}

feito em Code Blocks
Mensagens : 6
Data de inscrição : 20/09/2017
Ver perfil do usuário

Rhuan Ferreira l RA: 5944541684 l 2° Período

em Qua Nov 22, 2017 10:31 pm
Programa em C que preenche uma matriz de 5 linhas X 5 colunas.

#include <stdio.h>
int main(void) {

int matriz [5][5] = {{1,2,3,4,5},
{6,7,8,9,10},
{11,12,13,14,15},
{16,17,18,19,20},
{21,22,23,24,25}};

for (int m = 0; m < 5; ++m) {
for (int n = 0; n < 5; ++n) {
printf ("%i", matriz [m][n]);
}
printf("\n");
}


return 0;
}
Mensagens : 3
Data de inscrição : 20/09/2017
Ver perfil do usuário

Car

em Qua Nov 22, 2017 10:33 pm
Programa compilado por PascalZim!

Algoritmo que soma duas matrizes onde o usuário específica qual a dimensão da matriz.


Program soma_matrizes;
 Var
     A,B,C: array[1..100,1..100] of integer;
     i,j: integer;
     M,N: integer;
 Begin
     Writeln('digite as dimensões das matrizes:');
     Readln(N,M);
     Writeln('digite os elementos da matriz A:');
     For i:=1 to N do Begin
        For j:=1 to M do Begin
   Read(A[i,j]);
End;
Readln;
     end;
     Writeln('digite os elementos da matriz B:');
     For i:=1 to N do Begin
        For j:=1 to M do Begin
   Read(B[i,j]);
End;
Readln;
     end;
   
     For i:=1 to N do Begin
        For j:=1 to M do Begin
   C[i,j]:=A[i,j]+B[i,j];
End;
    End;
   
    Writeln('O resultado da soma de A+B:');        
      For i:=1 to N do Begin
        For j:=1 to M do Begin
   Write(C[i,j],'  ');
End;
Writeln;
    End;
 End.
Mensagens : 5
Data de inscrição : 19/09/2017
Ver perfil do usuário

DIOGO NEVES RA 1839605115 2° PERIODO

em Qua Nov 22, 2017 10:53 pm
criar uma matriz com 4 linhas e 4 colunas  e ler os valores correspondentes
programa compilado do visualg

var
matriz : vetor[0..3,0..3] de inteiro
contador1,contador2:inteiro
inicio
// linha 0
matriz[0,0]<-0
matriz[0,1]<-1
matriz[0,2]<-0
matriz[0,3]<-0
// linha 1
matriz[1,0]<-1
matriz[1,1]<-0
matriz[1,2]<-0
matriz[1,3]<-0

// lendo valores para matriz
para contador1 de 0 ate 1 faca
para contador2 de 0 ate 3 faca
escreva(matriz[contador1,contador2])
fimpara
escreval("")
fimpara
fimalgoritmo
Mensagens : 6
Data de inscrição : 20/09/2017
Ver perfil do usuário

Pedro Dezerto 2° periodo Ra: 5465901067

em Qua Nov 22, 2017 10:57 pm
4. Faça um programa que lê uma matriz de 3 x 3 elementos usando um comando for,
multiplica cada elemento por 5 e imprime o resultado.


#include <stdio.h>
#include <stdlib.h>
int main(){
int i, j, m[3][3];
//captura os elementos
for(i=0;i<3;i++)
for(j=0;j<3;j++){
printf("Elemento[%d][%d]= ",i,j);
scanf("%d",&m[i][j]);
}
//EXIBIR VALORES ORIGINAIS
printf("\n::: Valores Originais :::\n");
for(i=0;i<3;i++){
for(j=0;j<3;j++)
printf("%d ",m[i][j]);
printf("\n");
}
//multiplica por 5
for(i=0;i<3;i++)
for(j=0;j<3;j++)
m[i][j]=m[i][j]*5;
//EXIBIR VALORES MULTIPICADOS
printf("\n::: Valores Multiplicados por 5:::\n");
for(i=0;i<3;i++){
for(j=0;j<3;j++)
printf("%d ",m[i][j]);
printf("\n");
}
return 0;

}
Mensagens : 5
Data de inscrição : 16/09/2017
Ver perfil do usuário

Vitor Ielio Mattos de Azevedo RA: 1836544581 2° Periodo

em Qua Nov 22, 2017 11:01 pm
Faça um programa que carregue dois vetores de 10 elementos numéricos cada um e os envie para uma função que cria e escreve o vetor resultante da intercalação desses dois vetores.

#include <stdio.h>
#include <conio.h>

main() {

int vetorA[10], vetorB[10], vetorC[20];
int i, j=0, x=0;

//Entrada de dados
for(i=0; i<10; i++)
{
printf("\n\n Informe o %d%c valor do vetor A : ", i+1, 167);
scanf("%d", &vetorA[i]);
system("cls");
}
for(i=0; i<10; i++)
{
printf("\n\n Informe o %d%c valor do vetor B : ", i+1, 167);
scanf("%d", &vetorB[i]);
system("cls");
}
printf("\n\n Vetor A = ");
for(i=0; i<10; i++)
{
printf(" %d", vetorA[i]);
}
printf("\n\n Vetor B = ");
for(i=0; i<10; i++)
{
printf(" %d", vetorB[i]);
}
//Processamento
for(i=0; i<20; i++)
{
if(i%2==0)
{
vetorC[i]=vetorA[x];
x++;
}
else
{
vetorC[i]=vetorB[j];
j++;
}
}
//Saida em tela
printf("\n\n Vetor B = ");
for(i=0; i<20; i++){
printf(" %d", vetorC[i]);
}
printf("\n\n");
system("pause");
}
avatar
Mensagens : 6
Data de inscrição : 17/09/2017
Idade : 31
Ver perfil do usuário

Matrizes

em Qua Nov 22, 2017 11:27 pm
algoritmo “Estudando Matriz”

// Função : Faça um algoritmo para ler uma matriz de 3×4 de números reais
// e depois exibir o elemento do canto superior esquerdo e do canto inferior direito
// Autor : Adão Braga
// Data : 26/6/2011
// Seção de Declarações

var
matriz : vetor[1..3,1..4] de real
i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 3 faca
para j de 1 ate 4 faca
escreva(“Digite um número inteiro: [“, i, “,”, j, “] “)
leia(matriz[i,j])
fimpara
fimpara

para i de 1 ate 3 faca
para j de 1 ate 4 faca
escreva(matriz[i,j]:3)
fimpara
escreval(“”)
fimpara
escreval(“”)
escreval(“linha 1 e coluna 1”, matriz[1,1])
escreval(“linha 3 e coluna 4”, matriz[3,4])

fimalgoritmo
Conteúdo patrocinado

Re: Exercício 6 - 16/11/2017

Voltar ao Topo
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum